
                                                        
 

DATALINKSTM QUICK START GUIDE  

DataLinks allows you to access all your data regardless of its location or format from one 
user interface, build custom reports using drag-and-drop tools and push the resulting data 
set to Excel where it can be refreshed live against the data source with one click of your 
mouse.  

Using DataLinks you can connect to virtually any data source regardless of file format.  
DataLinks has built in connectors to the following data formats and can be configured to 
connect to any ODBC compliant data source:  
SQL Server  DB2 AS400  
Oracle  CSV (Comma delimited)  

Access  Excel  
DB2 Client Server  ODBC  

Normally, you will generate the report in an Excel workbook, where you can manipulate 
the data further, create graphics, and print.  DataLinks also allows you to export your 
report in XML or CSV formats so you can manipulate the data using other third-party 
tools.  

Using DataLinks to create a refreshable report in Excel is an easy three step process:  

1. Create a connection to a data source.  
2. Build your query exactly the way you want it in your report.  
3. Preview your report and export the data to Excel.  
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Before we show you how to create your report if you have not already done so, download 
and install DataLinks using the following instructions.  

Installing & Activating DataLinks  

1. Click on the link below to begin the download process  

http://www.BusinessIntelligenceLLC.com/trialinfo.php  

Please enter your user information and proceed to the download page.  

1. The file download dialog box will prompt you to Open, Save, or Cancel.  We suggest 
you choose 'Save' and choose a convenient location (such as the desktop) on your 
computer.  

2. Once the download is complete, go to the downloaded file (DataLinks.zip) and 
double-click on the file.  

3. Launch the file 'Setup.Exe'.  This will start the installation wizard.  Answer the 
questions presented until the process is completed, then press the 'Close' button. 
DataLinks is now installed.  

Starting DataLinks and Activating Your License  

1. Launch DataLinks.  Click Start > All Programs > Business Intelligence > DataLinks.  
2. On opening you will be prompted to Active DataLinks.  Click on the 'Activate 

DataLinks' button.  (NOTE: The Use Trial Version button is available for a limited 
period of time from when the product is originally installed.  After that you will need 
to purchase a license to continue to use the product.)  

3. The DataLinks Activation dialog box will appear.  After reading the license 
agreement check the 'I Agree to All the Terms and Conditions Listed Above' box 
and type in the serial number provided to you at the time of your purchase.  

You are now ready to use DataLinks.  

Navigating the DataLinks User Interface  

DataLinks can be started from the Windows Start menu by selecting Start > All Programs 
> Business Intelligence > DataLinks or you can start DataLinks from within Excel clicking 
on the BI Logo in the DataLinks toolbar.  The DataLinks user interface consists of a 
window with five panes.   

Starting in the lower left corner and proceeding clockwise, you find the DataSource pane 
(1) Where the sources of data that you point DataLinks to show up.  Once you have set 
up a datasource and clicked on the radio button next to it in the DataSource pane, the 
Database pane  

http://www.businessintelligencellc.com/trialinfo.php
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(2) Shows the table and column structure of the data.  You then build your query by 
dragging and dropping entire tables or individual columns from your datasource into the 
Selection Pane  

(3). If you want to apply any filters to your query, drag individual columns from the 
Database or the Selection Panes to the Criteria Pane  

(4). At any time that you are building your query you can preview the results in the 
Preview Pane  

(5) by selecting File > Preview Query Results from the main menu in DataLinks.  

 
 

Configuring a DataSource  

Each datasource type (SQL Server, Oracle, Access, DB2, CSV, Excel, Generic ODBC) has a 
slightly different configuration screen.  Sources that consist of individual files like Access 
databases, Excel workbooks or CSV files require only that you have access to and know 
the name and location of the file you wish to point to.  

To connect to other relational databases like SQL Server, Oracle, DB2, etc. all you need to 
know is the name of the server on the network on which the database resides and the 
name of the database.  You do not need to have any admin, reporting or other 
components of the database installed in order to connect to data in these formats using 
DataLinks.  What this means is that you have access to ALL your data from the DataLinks 
user interface.  If you want to grab some data from a SQL server datasource you click on 
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the radio button next to that datasource in DataLinks and immediately you see and can 
query and export your SQL data.  Click on a datasource pointing to a DB2 database stored 
on another server and your DB2 data is available for you to query.  No more starting up a 
SQL Server admin tool and then a DB2 admin tool just to get at two different sets of data.  

The following example illustrates how to connect to a SQL server datasource.  Follow the 
connection wizard to connect to other datasources.  

Step 1  

Open DataLinks and click on DataSources > New DataSource on the main menu  

 

Enter a friendly name for your datasource in the DataSource Name text box.  This is the 
name that DataLinks will display in the DataSource pane so be sure it properly identifies 
the datasource to you.  Select SQL Server from the drop down list to identify the file type 
as a SQL Server database.  Click Next to continue.  
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Step 2 -Select Use the Data Link wizard to generate a connection string and click Next to 
continue.  

 

Click on Launch Data Link wizard to create the connection string that DataLinks needs to 
connect to your SQL Server database files.  

 

Select or enter a server name in the text box.  If you click on the drop down list DataLinks 
will make an effort to scour the network for possible services with a SQL Server database 
on it.  Depending on the network configuration the server you want may not be listed.  If 
it is not, you can enter the name manually.  

Most IT departments allow for a single login and thus your windows credentials are 
sufficient to log you in to a database to which you have been granted access.  If this is 
how your network security is set up, click the radio button to the left of Use Windows NT 
Integrated security.  If you are required to login separately, enter the login information 
here so you do not need to login every time you select this datasource in DataLinks.  

Select the database name from the drop down list or enter it here if you know it.  Click 
Test Connection to see if the information you have entered is correct.  If an error is 
returned, check your settings and make the changes necessary.  If you get a Test 
Connection OK message, click OK to continue to the next step.  
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Step 3  

Click finish and DataLinks will store all the information it needs to connect to this 
datasource again at the click of your mouse.  

 

You will now see your new SQL Server datasource in the lower left or DataSource pane of 
DataLinks.  Click on the radio button next to the new datasource and your SQL Server 
data will now show up in the Database pane of DataLinks as separate tables and views.  

Building, Running and Saving a DataLinks Query  

After you have configured a datasource you can click on the radio button next to it in the 
DataSource pane and your data will show up in the Database pane as Tables and Views 
(or Queries).  You can drill down into the Tables and Views to expose the columns or fields 
in each.  If your datasource has relationships that are properly declared in it, DataLinks 
will show those related tables in the database pane.  (Note: Refer to the DataLinks User 
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Guide for more information on how to create your own relationships between tables within 
DataLinks.)  

 

 

Remember the easy three step process for building your query as illustrated above:  

1. Select your datasource in the DataSources Pane by clicking on the radio button 
next to the datasource you want to query.  

2. In the Database Pane drill down into the database to view the tables and fields you 
want to include in your query.  Drag and drop the fields or an entire table from the 
Database pane into the Selection Pane.  (Note: if you select data from more than 
one table you must be sure that a relationship exists between the tables in the 
database itself or you must create a relationship of DataLinks will be unable to 
return a meaningful dataset from the datasource.  See the DataLinks User Guide for 
more information on how to create relationships using DataLinks.)  

3. To apply a filter to your data drag the field you wish to filter on into the Criteria 
Pane and select the criteria and value you wish to filter on. (Note: If you do not 
know the values in the datasource you can click on the icon in right side of the 
value box in the criteria pane to have DataLinks provide you with a drop down list 
of valid values).  At any time you can preview the results of your query by selecting 
File > Preview Query Results from the main DataLinks menu.  To save your query, 
simply click on File > Save Query and choose a folder and filename to save it for 
future use.  (Note: these saved query files can be shared with other DataLinks 
users to ensure the exact same query gets run each time.)  
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Exporting Your Report to Excel  

When you are satisfied with the results of your query in DataLinks, you can export the 
resulting dataset into Excel via a refreshable connection.  (Note: You can also choose to 
export the data in XML or CSV format if you want to use a presentation program other 
than Excel to view the data.)  

Select File > Export Query Results > Export Query Results to Excel. DataLinks will bring 
up the following screen.  

 

If the resulting dataset is less than the maximum number of rows in an Excel workbook 
(currently 65,535 rows) you will have the option of exporting your report in an Excel 
Query Table (i.e., raw data) or an Excel Pivot Table (i.e., summary data) formats.  If, on 
the other hand you are working with large datasets that exceed the row count in Excel, 
the Excel Query Table option will be grayed out, however the Excel Pivot Table option will 
still be available.  This example assumes the data is exported in Excel Query Table format.  

Select the Excel workbook you wish to export the data to and click Export Query Results 
to generate the report in Excel.  (Note: if you choose to export the report to an open Excel 
workbook, the report will be generated in Excel wherever the cursor is.  Be sure and check 
that the cursor is in the right place in your Excel workbook before clicking on the Export 
Query Results button.)  
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DataLinks sends the query to the datasource and pushes the resulting dataset out to Excel 
in a refreshable connection.  What this means is that when you want to refresh the data in 
your Excel report against the datasource, you simply click somewhere in your report in 
Excel and select Data > Refresh Data from the main Excel menu.  The query is then sent 
back to the datasource and the new dataset is reflected in your report.  

For More Information:  

Website: http://www.BusinessIntelligenceLLC.com  
Technical Support: Support@BusinessIntelligenceLLC.com  

Sales:  Sales@BusinessIntelligenceLLC.com  
Suggestions:  Support@BusinessIntelligenceLLC.com  
Telephone:  (610) 971-4067  

 

http://www.businessintelligencellc.com/

